WordPress 5.0 mit Gutenberg-Editor ist da


WordPress 5.0 mit Gutenberg-Editor ist da

Das Entwicklungsteam von WordPress hat in der Nacht zum Freitag die finale Version 5.0 der gleichnamigen Blogsoftware veröffentlicht. Mit diesem Update erhält WordPress einen neuen Editor namens Gutenberg mit vielen Änderungen gegenüber dem klassischen Editor. Der neue Editor soll laut WordPress der erste Schritt hin zu einer Zukunft mit einer vereinfachten Bearbeitungs-Erfahrung über die komplette Website hinweg sein. Der Editor wird demnach nicht ändern, wie Inhalte auf eurer Site für Besucher sichtbar sind. Wenn ihr aus irgendeinem Grund den klassischen Editor behalten möchtet oder müsst, könnt ihr das über das Plug-in namens Classic Editor tun. Die Unterstützung dafür wird es in WordPress bis 2021 geben. Das Plug-in deaktiviert Gutenberg und stellt den alten Editor wieder her, sodass ihr weiter Plug-ins nutzen könnt, die diesen Editor erweitern oder irgendwie anders davon abhängen.

WordPress

Twenty Nineteen heißt das neue Theme von WordPress 5.0, es bietet individuelle Stile für die Blöcke, die standardmäßig in 5.0 verfügbar sind. Mit diesem Update wurden alle bisherigen Standard-Themes, von Twenty Ten bis Twenty Seventeen, aktualisiert, um den Block-Editor zu unterstützen. Das Update auf die finale Version von WordPress 5.0 kann ab sofort über die offizielle Website heruntergeladen werden. Weitere Informationen zu diesem Update finden sich weiter unten oder im offiziellen WordPress Blog.

Download -> WordPress 5.0 Bebo mit Gutenberg-Editor herunterladen

Die Version 5.0 von WordPress kann über die Webseite von WordPress geladen werden:

Was ist neu in WordPress 5.0?

Die Version 5.0 enthält die folgenden Neuerungen und Verbesserungen:

Block-Editor

  • WordPress 5.0 stellt den neuen Block-Editor (Gutenberg) vor. Es soll mehr Flexibilität bei der Darstellung von Inhalten bieten und wird bereits auf vielen Websites getestet.
  • Wer noch Zeit für die Umstellung benötigt, kann das Plug-In Classic Editor installieren. Damit wird weiterhin der klassische Editor nach der Aktualisierung auf WordPress 5.0 verwendet.

Theme Twenty Nineteen

  • Twenty Nineteen heißt das neue Theme von WordPress 5.0, es bietet individuelle Stile für die Blöcke, die standardmäßig in 5.0 verfügbar sind. Twenty Nineteen wurde entwickelt, um mit einer Vielzahl von Anwendungsfällen zu arbeiten. Egal, ob du einen Fotoblog betreibst, ein neues Unternehmen gründest oder eine gemeinnützige Organisation unterstützt, Twenty Nineteen ist flexibel genug, um deine Bedürfnisse zu erfüllen.

Außerdem wurden auch einige kleinere Änderungen vorgenommen, darunter:

  • Alle bisherigen Standard-Themes, von Twenty Ten bis Twenty Seventeen, wurden aktualisiert, um den Block-Editor zu unterstützen.
  • Du kannst die Zugänglichkeit der von dir geschriebenen Inhalte verbessern, da nun einfache ARIA-Labels in Beiträgen und Seiten gespeichert werden können.
  • WordPress 5.0 unterstützt offiziell die kommende Version von PHP 7.3: Wenn du eine ältere Version verwendest, wird empfohlen, PHP auf deiner Website zu aktualisieren.
  • Entwickler können nun mit den neuen JavaScript-Sprachpaketen übersetzbare Strings direkt zu ihrem JavaScript-Code hinzufügen.

Plugin- und Theme-Entwickler

  • Plugin- und Theme-Entwickler werden gebeten, ihre Themes und Plugins mit WordPress 5.0 zu testen und das „Getestet mit“ in der Liesmich-Datei auf Version 5.0 zu aktualisieren.

via WordPress Blog